Discussion:
Installing Marpa::R2 on Red Hat Enterprise Linux Server release 7.1 (Maipo)
(too old to reply)
p***@free.fr
2015-08-17 07:30:58 UTC
Permalink
Hello,

I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are some
of the warning messages I get in *CPAN*:

l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for 'JKEGL/Marpa-R2-3.000000.tar.gz'
failed when processing 'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine
prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.

Philippe
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Ruslan Shvedov
2015-08-17 07:42:39 UTC
Permalink
Which version of perl are you using?

Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1], which is
required to build Marpa::R2.

An issue has been filed to check for minimum perl version [2].

[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was all
just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818

[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for 'JKEGL/Marpa-R2-3.000000.tar.gz'
failed when processing 'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine
prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
p***@free.fr
2015-08-17 08:06:37 UTC
Permalink
Hi,

This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1], which
is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was all
just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine
prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Ruslan Shvedov
2015-08-17 08:17:08 UTC
Permalink
Hi,
Post by p***@free.fr
Hi,
This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
hmm, according to cpantesters [1] Marpa::R2 3.00 passes with 5.16.3 under
linux.

Perhaps try cpanm or change cpan config to auto-install pre-reqs per this
answer -- http://stackoverflow.com/a/14067234/4007818?

[1]
http://fast-matrix.cpantesters.org/?dist=Marpa-R2%203.000000;perl=5.16.3;reports=1
Post by p***@free.fr
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1], which
is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was
all just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to
determine prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
p***@free.fr
2015-08-17 08:26:44 UTC
Permalink
Unfortunately, cpanm is not installed on Red Hat 7.1, and "yum info cpanm"
results in a "not found" message.

My CPAN prerequisite policy is already equal to [follow].

Philippe
Post by Ruslan Shvedov
Hi,
Post by p***@free.fr
Hi,
This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
hmm, according to cpantesters [1] Marpa::R2 3.00 passes with 5.16.3 under
linux.
Perhaps try cpanm or change cpan config to auto-install pre-reqs per this
answer -- http://stackoverflow.com/a/14067234/4007818?
[1]
http://fast-matrix.cpantesters.org/?dist=Marpa-R2%203.000000;perl=5.16.3;reports=1
Post by p***@free.fr
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1], which
is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was
all just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to
determine prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Ruslan Shvedov
2015-08-17 08:56:54 UTC
Permalink
Well, in such cases I usually try installing dependencies individually,
perhaps starting with Capture::Tiny, which blocks Config::AutoConf and
Module::Build::Tiny,
which, among others, block PPI.

Also, cpan strangely falls back to Config::Autoconf, while on linux it
should rather use configure. Stupid question as it is, but do you have
recent autotools installed?
Post by p***@free.fr
Unfortunately, cpanm is not installed on Red Hat 7.1, and "yum info cpanm"
results in a "not found" message.
My CPAN prerequisite policy is already equal to [follow].
Philippe
Hi,
Post by p***@free.fr
Hi,
This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
hmm, according to cpantesters [1] Marpa::R2 3.00 passes with 5.16.3
under linux.
Perhaps try cpanm or change cpan config to auto-install pre-reqs per this
answer -- http://stackoverflow.com/a/14067234/4007818?
[1]
http://fast-matrix.cpantesters.org/?dist=Marpa-R2%203.000000;perl=5.16.3;reports=1
Post by p***@free.fr
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1],
which is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was
all just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to
determine prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
p***@free.fr
2015-08-17 09:44:16 UTC
Permalink
*autotools *is not installed on this machine.

Because this a production server, I don't want to install tools like *autotools
*and mess with the *PERL *installation.

Thanks for your help anyway.
Post by Ruslan Shvedov
Well, in such cases I usually try installing dependencies individually,
perhaps starting with Capture::Tiny, which blocks Config::AutoConf and Module::Build::Tiny,
which, among others, block PPI.
Also, cpan strangely falls back to Config::Autoconf, while on linux it
should rather use configure. Stupid question as it is, but do you have
recent autotools installed?
Post by p***@free.fr
Unfortunately, cpanm is not installed on Red Hat 7.1, and "yum info
cpanm" results in a "not found" message.
My CPAN prerequisite policy is already equal to [follow].
Philippe
Hi,
Post by p***@free.fr
Hi,
This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
hmm, according to cpantesters [1] Marpa::R2 3.00 passes with 5.16.3
under linux.
Perhaps try cpanm or change cpan config to auto-install pre-reqs per
this answer -- http://stackoverflow.com/a/14067234/4007818?
[1]
http://fast-matrix.cpantesters.org/?dist=Marpa-R2%203.000000;perl=5.16.3;reports=1
Post by p***@free.fr
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1],
which is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was
all just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to
determine prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it,
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Ruslan Shvedov
2015-08-17 09:15:44 UTC
Permalink
Also, you can go on marpa irc channel -- #marpa on irc.freenode.net --
perhaps there is somebody more experienced in the platform.
Post by p***@free.fr
Unfortunately, cpanm is not installed on Red Hat 7.1, and "yum info cpanm"
results in a "not found" message.
My CPAN prerequisite policy is already equal to [follow].
Philippe
Hi,
Post by p***@free.fr
Hi,
This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
hmm, according to cpantesters [1] Marpa::R2 3.00 passes with 5.16.3
under linux.
Perhaps try cpanm or change cpan config to auto-install pre-reqs per this
answer -- http://stackoverflow.com/a/14067234/4007818?
[1]
http://fast-matrix.cpantesters.org/?dist=Marpa-R2%203.000000;perl=5.16.3;reports=1
Post by p***@free.fr
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1],
which is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was
all just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to
determine prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Ruslan Shvedov
2015-08-17 09:18:56 UTC
Permalink
Post by p***@free.fr
Unfortunately, cpanm is not installed on Red Hat 7.1, and "yum info cpanm"
results in a "not found" message.
FWIW, there is more than one way to install cpanm, e.g. cpan App::cpanminus
and others --
http://search.cpan.org/~miyagawa/App-cpanminus-1.7039/lib/App/cpanminus.pm

Ruslan
Post by p***@free.fr
My CPAN prerequisite policy is already equal to [follow].
Philippe
Hi,
Post by p***@free.fr
Hi,
This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi
(with 28 registered patches, see perl -V for more detail)
hmm, according to cpantesters [1] Marpa::R2 3.00 passes with 5.16.3
under linux.
Perhaps try cpanm or change cpan config to auto-install pre-reqs per this
answer -- http://stackoverflow.com/a/14067234/4007818?
[1]
http://fast-matrix.cpantesters.org/?dist=Marpa-R2%203.000000;perl=5.16.3;reports=1
Post by p***@free.fr
Which version of perl are you using?
Looks like Red Hat 7.1 by default has no perl version >= 5.10 [1],
which is required to build Marpa::R2.
An issue has been filed to check for minimum perl version [2].
[1] Red Hat 7.1 (not RHEL, but back before Fedora and RHEL when it was
all just Red Hat Linux) from 2001 had 5.6.0 in the ISOs.
-- http://www.perlmonks.org/?node_id=879818
[2] https://github.com/jeffreykegler/Marpa--R2/issues/257
Post by p***@free.fr
Hello,
I am having trouble installing *Marpa::R2* on *Red Hat 7.1.* Here are
l /usr/lib64/perl5 /usr/share/perl5 .) at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# BEGIN failed--compilation aborted at
/root/.cpan/build/Config-AutoConf-0.311-2MOxbU/blib/lib/Config/AutoConf.pm
line 20.
# Compilation failed in require at t/00.load.t line 7.
# BEGIN failed--compilation aborted at t/00.load.t line 7.
FAILED--Further testing stopped: Can't load Config::AutoConf
make: *** [test_dynamic] Error 255
REHSACK/Config-AutoConf-0.311.tar.gz
one dependency not OK (Capture::Tiny); additionally test harness failed
/usr/bin/make test -- NOT OK
reports REHSACK/Config-AutoConf-0.311.tar.gz
Running make install
make test had returned bad status, won't install without force
Running make for J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
Warning: Prerequisite 'PPI => 1.206' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'MITHALDU/PPI-1.220.tar.gz' with 'make_test => NO 7 dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed'. Continuing, but chances to succeed are
limited.
Warning: Prerequisite 'Time::Piece => 1.12' for
'JKEGL/Marpa-R2-3.000000.tar.gz' already built but the result looks
suspicious. Skipping another build attempt, to prevent looping endlessly.
Warning: Prerequisite 'Config::AutoConf => 0.22' for
'JKEGL/Marpa-R2-3.000000.tar.gz' failed when processing
'REHSACK/Config-AutoConf-0.311.tar.gz' with 'make_test => NO one dependency
not OK (Capture::Tiny); additionally test harness failed'. Continuing, but
chances to succeed are limited.
CPAN.pm: Building J/JK/JKEGL/Marpa-R2-3.000000.tar.gz
/usr/local/share/perl5 /root/perl5/lib/perl5/x86_64-linux-thread-multi
/root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at
inc/Marpa/R2/Build_Me.pm line 32.
BEGIN failed--compilation aborted at inc/Marpa/R2/Build_Me.pm line 32.
Compilation failed in require at Build.PL line 29.
BEGIN failed--compilation aborted at Build.PL line 29.
Warning: No success on command[/usr/bin/perl Build.PL ]
JKEGL/Marpa-R2-3.000000.tar.gz
/usr/bin/perl Build.PL -- NOT OK
Running Build test
Make had some problems, won't test
Running Build install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to
determine prerequisites
LEONT/ExtUtils-InstallPaths-0.011.tar.gz : make_test NO one
dependency not OK (ExtUtils::Config); additionally test harness failed
LEONT/Module-Build-Tiny-0.039.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
ETHER/Hook-LexWrap-0.25.tar.gz : make_test NO one
dependency not OK (Module::Build::Tiny)
ADAMK/Test-SubCalls-1.09.tar.gz : make_test NO one
dependency not OK (Hook::LexWrap); additionally test harness failed
MITHALDU/PPI-1.220.tar.gz : make_test NO 7
dependencies missing
(File::Remove,Params::Util,Clone,Test::Object,Test::SubCalls,Class::Inspector,Task::Weaken);
additionally test harness failed
REHSACK/Config-AutoConf-0.311.tar.gz : make_test NO one
dependency not OK (Capture::Tiny); additionally test harness failed
JKEGL/Marpa-R2-3.000000.tar.gz : writemakefile NO
'/usr/bin/perl Build.PL ' returned status 512
Here's my CPAN version
/usr/bin/cpan script version 1.5701, CPAN.pm version 1.9800
Any help would be much appreciated.
Philippe
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google
Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups
"marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "marpa parser" group.
To unsubscribe from this group and stop receiving emails from it, send an email to marpa-parser+***@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Loading...